SupportMotoThe racing suit compatible with the In&motion airbag system
Back

The racing suit compatible with the In&motion airbag system

The In&motion airbag system was conceived to be worn under a motorcycle jacket. However, the system is not compatible with other elements.

The explanation is simple: when the airbag will deploy, it will go up under the helmet in order to protect from a neck hyper-extension.  If you wear a jacket (that is not zipped with your motorcycle trousers), no worries, the airbag can easily go up and deploy correctly… if you wear a suit, it won’t be the case and it might compromise the correct deployment of the airbag in case if incident.

The In&motion airbag system is not compatible with jackets having a support in the crotch and cannot be worn with a jacket zipped to your trousers

Therefore, airbag vests equipped with In&motion technology can only be worn in compatible suits. For the moment, only 7 suits are compatible with the In&motion system:

In addition, the new race dept V4.1 Airbag leather suit from our partner brand RST incorporates the In&motion airbag system.

Please note that your airbag product already integrates a back protector and that wearing a back protector in addition to the one already included in your airbag vest may lead to a malfunctioning of the system in case of an incident.

For your safety, if your race suit already includes a back protector, consider removing it when wearing the airbag underneath.

The In&motion system is compatible provided you have taken a combination to your size. Be sure to choose the appropriate size corresponding to your body shape according to the size guide.

Warning, using the In&motion airbag system under a non compatible suit may lead to a malfunctionning of the system in case of incident. 

You did not find what you were looking for ?
We suggest you visit our website designed especially for your location to get the right content and product availability.

In&motion

Votre navigateur est obsolète

Pour profiter du site,
merci de mettre à jour votre navigateur